View Full Version : Solved: Disappearing Command Buttons (ActiveX and Forms type) when copying sheet...

11-15-2011, 05:10 AM
Hi All:

I'm currently in Excel 2010 (XP/WIN), do not have access at the moment to an older version at the moment, and am more baffled than usual...:stars:

On a regular worksheet, I install both activex and forms toolbar type command buttons. If I copy the sheet (to the same workbook no less), the buttons do not go with.

Blond, sleep deprived, etc.; still, that's just goofy, right?

Anyone want to tell me what I just goobered or missed (some new wacky option or setting maybe?)?

Thank you so much,


11-15-2011, 05:32 AM
Assuming you mean that you are copying the entire sheet, not just the cells, then no that should not happen, and does not for me (Office 2010 SP1, Windows XP).
Is the file an old format file and were the buttons created in the older version?

11-15-2011, 06:03 AM
Hi Aflatoon:hi: ,

Thanks for answering; sorry I went offline for a moment. (click, "oops, damnit!")

Just for confirmation, the initial try was in an .xls format, but I also tried in a new/unsaved wb as well as saved new .xlsm.

I found it though... (recent change at work to 2010, too busy so far to really go thru it all, and we had 2003 prior, all add up to me slowly clunking thry things...)

11-15-2011, 06:09 AM
A follow-up just struck me, but found that as well.
Application.CopyObjectsWithCells = True
Phew! at least that's a relief.