View Full Version : My ActiveX doesn't work anymore

04-04-2006, 02:06 PM
Hi All,

I have some problem creating an ActiveX control to use in an Excel plugin.
I did this:
- created the version 1.0.0 of an ActiveX control in VB6
- inserted it in an Excel plugin form
- set the binary compatibility to the control v1.0.0
- added 2 properties to the control
- compiled and created the control v1.0.1
At this point the Excel plugin stopped working.
Removing the 2 new properties and recompiling it re-worked, adding them it didn't. According to http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon98/html/vbconversioncompatibility.asp?frame=true (http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon98/html/vbconversioncompatibility.asp?frame=true) it should work, but it doesn't.

I gave it up and decided to restart:
- removed the ActiveX from the Excel plugin
- unregistered the plugin
- removed compatibility to the VB6 project
- added the 2 properties
- created a brand new v1.0.0 (with the same name)
- added the control to the Excel plugin form
At this point the control works, but I get the message "This application is about to initialize ActiveX controls that might be unsafe". I can work if I load the macro manually and click on OK, but fails if I click on the toolbar button that loads the plugin.

Why didn't the message appear on the first first version and it appears on the second first version?

How can I get rid of it?

I tried to create a new ActiveX with a different name and... even this has the same problem.

I didn't change any setting in the Excel security options.