View Full Version : Solved: Firefox not working (again)

Zack Barresse
04-16-2006, 12:39 PM
Okay, well somehow I managed to screw up my FireFox - again! This happened just after I loaded up the Office 12 Beta and I opened firefox (unknown if the install is related or not) and it said I had to upgrade, so I downloaded the update and ran it straight from the download.

I received the error message that I had to quit all instances of firefox and then try again. Weird thing was, there was no open firefox running. Opened the task manager and found four instances of firefox! Tried to end the process but it wouldn't do it, they just kept right on chugging along. The pc performance did not seem to be hindered even the slightest bit.

Eventually I had to shut the pc down and run the FF setup exe again. It seemed to run fine and I've got version. The only problem is now when I open FF up it's a blank screen. I can view all web pages fine with all other browsers I've tried, just not FF anymore.

I tried resetting the default browser to IE, tried FF, then reset FF to the default, tried it, nothing. In the status bar it says "Looking up www.google.com...", my home page, as it does if you have no internet connection. (For those who work on a wireless network of sorts have probably seen this quite a bit.)

I have tried to reset all web settings a couple of times, reloaded the FF setup, uninstalled, reinstalled, etc. No go. Not sure what to do now. Anybody else have this issue? It's only with the pc at my work, home is still chugging right along.

Jacob Hilderbrand
04-16-2006, 01:38 PM
Do you have any firewall settings that could be blocking the application? For example, I have Nortan Internet Security and I have to allow the applications I want to have internet access otherwise the application will be blocked.

Zack Barresse
04-17-2006, 08:45 AM
I did download/install Windows Defender. It asked me if I wanted to allow the application (as it did with IE), which I set all to Allow. I have Norton's but haven't done anything with that in a while, no settings changes or anything there.

04-20-2006, 04:40 PM
Why don't you try to remove FF completely and start all over by downloading the newest version?

Just a thought...

Zack Barresse
04-25-2006, 09:40 AM
I did that. No luck. I think it's in the settings somewhere, but I'm not too sure. Another thought of mine is it might be some of the new security updates from MSFT. They played hell with my Office apps too.

04-30-2006, 06:37 PM
If it keep saying "Looking up Google.com...", try entering this in the address bar: (IP Address for Google). If it's still looking it up, it's trying to resolve the IP address. Not sure why it stopped working all of a sudden.

Firefox has a few issues lately. Their workaround for the lost bookmarks problem is moronic. Instead of finding out why and fixing that, they just have Firefox backup the bookmarks when you close the program 'just in case'.

Opera seems to work just as good, offers tabs, and seems to be just as fast, if not faster.

07-19-2006, 09:34 PM
Zack, it's getting late for me and i'm too tired to research this, but have you considered posting your question at the Mozilla forum? I've posted questions on their FF forum in the past and the responses have always been very helpful and fairly quick.


The fact that you did re-installed after FF crashed was a bad move - but that's just MHO. Sounds like you did a dirty install - yes? When you rebooted your PC after the crash, did you start up FF again or re-install FF right away? IMHO it would have been better to see if FF would start up again properly. I'm too brain-dead at the moment, but I seem to remember there is a file in your Mozilla profile folder which sort of acts like a error trapper if you will when FF crashes. Tomorrow morning I will have some time and I can search through their forum archives. Buit in the meantime, could you answer some additional questions I have.

1) What version were you using before the upgrade attempt?
- in my experience, i have found completely uninstalling the old version is favorable when upgrading to a new major version. i.e. going from 1.0.8 to 1.5 for example

2) Did you have any extensions installed w/ your original installation?
- if so, those extensions may not be compatible w/ the latest version and thus may account for this strange anomoly. Unisntall any extensions you might have and see if the problem goes away.

Zack Barresse
07-24-2006, 02:35 PM
Well it seems to be working now. I ended up reformatting (for other issues) and upon reinstall it worked great. Not sure what the problem was actually. Thanks for everyone's help. Will definitely keep this info for reference in the future. :yes